月度归档:2020年12月

RouterOS 非官方升级镜像

因为 Mikrotik RouterOS 的官方升级镜像在国内访问实在是太慢了,因此自建了一个升级镜像,供大家使用。

设置方法:在 RouterOS 命令行中执行以下命令即可。

/ip dns static
add address=43.240.30.56 name=upgrade.mikrotik.com

镜像每天凌晨1点同步。

RouterOS 屏蔽小米电视广告

因为使用到了正则式以及NXDOMAIN,需要RouterOS版本为 6.47 或更新版本

/ip dns static
add regexp="(.*\\.)\?abtest\\.mistat\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?ad\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?ad1\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?bss\\.pandora\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?data\\.mistat\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?de\\.pandora\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?dvb\\.pandora\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?image\\.box\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?jellyfish\\.pandora\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?m\\.bss\\.pandora\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?notice\\.game\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?o2o\\.api\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?ppurifier\\.game\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?sdkconfig\\.ad\\.intl\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?shenghuo\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?storeconfig\\.mistat\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?wtradv\\.market\\.xiaomi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?a\\.hl\\.mi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?a\\.union\\.mi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?ad\\.mi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?migc\\.g\\.mi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?migcreport\\.g\\.mi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?mis\\.g\\.mi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?mivideo\\.g\\.mi\\.com\$" type=NXDOMAIN
add regexp="(.*\\.)\?staging\\.admin\\.e\\.mi\\.com\$" type=NXDOMAIN

以上代码直接复制进 RouterOS 的 Terminal 里执行即可。

域名规则来自 https://github.com/lhie1/Rules